The Attempting to open Microsoft Dynamics 365. If the application does not load within a few seconds, click HERE.

Advanced settings not loading in Power Platform

Yesterday one of my clients showed me an issues where the Advanced settings didn’t load.

Advanced Settings loading problem

When I selected the advanced settings the browser attempted to load the settings, However after waiting for a while a popup would appear.

Advanced settings not loading in Power Platform 1

This popup showed me the app within my environment rather than the settings page that I was after.

Advanced settings not loading in Power Platform 2

The clue is in the popup screen. If you look at the url there is the isappmeredirect=true parameter

.crm11.dynamics.com/main.aspx?isappmoderedirect=true&forceUCI=1&pagetype=apps

This parameter makes the advanced settings in the Power Platform and Dynamics 365 not load.

And if you are loading the advanced settings from Dynamics 365 you will find your main browser window appear like this

Advanced settings not loading in Power Platform 3

The Attempting to open Microsoft Dynamics 365. If the application does not load within a few seconds, click HERE.

Well if you click there, you will not get any further

Open in application mode setting

Then looking at the environment settings in the Power Platform Admin Center there is an option that will come to the rescue.

Advanced settings disabled when Open in application mode is on

The Open in application mode is the problem here. Switching this option as shown below resolved my issue and my advanced settings are happily opening again.

Advanced settings not loading in Power Platform 4

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: