Leaked record detected with address …, name (unknown), and thread local refcount

The following error is generated by a PowerShell script:

Leaked record detected with address 000000001D5ED488, name (unknown), and thread local refcount 73. To see AddRef/Release callstacks for this leak, run stsadm -o setproperty -pn refcountcallstacktrackingenabled -pv true.

The Solution

I found an article showing the same error:

However this wasn’t our problem.

I ran the PowerShell script in question in the ISE PowerShell Debugger and found the problem with this code:

foreach ($item in $List.Items)




Suddenly this was filling up my memory.

$List.Items loads all the list items and for a list with about 5000 items that is not a good idea. Running something like this is a better idea:

$spqQuery = New-Object Microsoft.SharePoint.SPQuery
$spqQuery.Query =

$spqQuery.ViewFields = “<FieldRef Name=’ID’ /><FieldRef Name=’Title’ />”
$spqQuery.ViewFieldsOnly = $true
$splListItems = $ulsList.GetItems($spqQuery)

foreach ($splListItem in $splListItems)


Avatar for Pieter Veenstra

By Pieter Veenstra

Business Applications and Office Apps & Services Microsoft MVP working as a Microsoft Productivity Principal Consultant at HybrIT Services. You can contact me using contact@veenstra.me.uk.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: